Le schéma des extensions de Kitcos

Kitco dispose de 3 ports d’extensions:

  1. Un port FTDI, en haut à gauche (qui sert à téléverser des programmes sur la console)
  2. Un port SPI (en bas, sous l’écran), qui peut servir à brancher, par exemple, un lecteur de carte SD
  3. Un port I²C (en dessous du port FTDI) qui permet de brancher des périphériques I²C (jusqu’à 256 en série!)

On peut également utiliser certaines broches de ces ports sans les autres pour avoir des entrées/sorties digitales ou analogiques (comme sur un Arduino).

Voici le schéma correspondant:

connections-kitco

On peut donc disposer, au choix de

  • trois ports d’interface
  • cinq entrées sorties digitales D0,D1, D11,D12,D13
  • trois entrées sorties analogiques A1, A4, A5

Attention cependant pour D11,D12,D13, elles ne peuvent être utilisées que lorsque l’on ne communique pas avec l’écran.

4 réflexions sur “Le schéma des extensions de Kitcos

  1. Bonjour je m’appelle Antoine. Je viens d’acquérir une console Kitco. J’ai fait les soudures, suivi les instructions du tutoriel, installer le driver, télécharger la librairie Kitco ainsi que le dossier hardware. Le soucis est que je ne retrouve pas la carte La console Kitco dans le menu outils/type de carte de l’ide Arduino. J’ai même télécharger une ancienne version de l’ide (1.6.7) comme suggérer dans les F.A.Q mais rien toujours le même message d’erreur dans la console : aucun fichier .h présent dans le dossier hardware. Pouvez-vous m’aider à résoudre le problème s’il vous plait ?

    J’aime

      1. Bonjour Francois.

        Oui j’ai vérifié les deux dossiers sont bien présents dans Mes Documents/Arduino. La console kitco apparait enfin dans la liste des cartes. Lorsque je charge une exemple : pas de soucis.

        Le nouveau rencontré est à l’étape de téléversement du code. Ca prend beaucoup de temps pour finalement échouer avec un message d’erreur :

        « Warning: Board breadboard:avr:atmega328bb doesn’t define a ‘build.board’ preference. Auto-set to: AVR_ATMEGA328BB »

        Il semble qu’il ait une erreur sur le système de boot builder.

        Auriez-vous une information à ce sujet s’il vous plait ?

        J’aime

  2. Hello Antoine,

    Quelques points à vérifier :
    – être en IDE 1.6.7
    – avoir bien sélectionné « La console Kitco » avant de faire le transfert
    – vérifier la présence du fichier boards.txt dans ….hardware\breadboard\avr
    – la carte FTDI est-elle bien en 3.3V

    si ça ne corrige pas:
    – est-ce que le comportement est le même si le cable usb est déranché?
    -est-ce que les soudures entre les points de la carte et le mircocontrolleur sont OK?

    François

    J’aime

Votre commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l’aide de votre compte WordPress.com. Déconnexion /  Changer )

Image Twitter

Vous commentez à l’aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l’aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s